How to Configure MC-LAG (Multi-Chassis Link Aggregation)

How to Configure MC-LAG (Multi-Chassis Link Aggregation)

MC-LAG (Multi-Chassis Link Aggregation) 

Objective 

This document explains how to configure MC-LAG (Multi-Chassis Link Aggregation) between two switches and a host. MC-LAG provides link redundancy and load balancing by allowing two physical switches to appear as a single logical LAG (Link Aggregation Group) to the connected host, improving resiliency and eliminating single points of failure. 

Prerequisites 

Hardware: 

  • Switches or routers that support VLANs 
    (e.g., edgecore, ufispace) 

Software: 

  • Network operating systems that support VLAN configuration 
    (e.g., SONiC-OS-4.4.0-Enterprise_Base, SONiC-OS-4.4.2-Enterprise_Base) 

Access: 

  • Administrative or privileged CLI access 

Network: 

  • Physical connections between Switch 1 and Switch 2 (peer-link or ICCP/ISL) 

  • Physical LAG (bonded) links from Switches to the host 

 

Topology Diagram 

Picture 

 
 

Example: 

Two switches connected via peer link, both uplinked to a single host using port-channel bonds for redundancy and load balancing. 

Basic Configuration Steps 

1. Configure Peer Link Between Switches 

Establish a dedicated link between Switch 1 and Switch 2 for control plane synchronization. 

2. Enable MC-LAG on Both Switches 

Configure the IP address on the dedicated management Ethernet port under the mgmt VRF. 

3. Configure MC-LAG Interface 

Define MC-LAG interface (logical LAG) and assign member ports. 

4. Configure LAG on Host 

Set up LACP bonding on the host to aggregate connections from both switches. 

Example Configuration (DUT_1 and DUT_2) 

 

DUT_1 

configure terminal 

interface PortChannel3  

switchport trunk allowed Vlan 100,200  

no shutdown  

 

interface PortChannel1  

switchport access Vlan 100  

mclag 1 

exit  

 

 

interface Ethernet47  

channel-group 3 

 

interface Ethernet0  

channel-group 1  

! 

 

interface Vlan200  

description peer-link_vlan  

ip address 192.168.1.1/24  

 
interface Vlan100  

ip anycast-address 10.10.10.1/24  

!   
 

mclag domain 1  

source-ip 192.168.1.1  

peer-ip 192.168.1.2  

peer-link PortChannel3  

mclag-system-mac 02:11:22:33:44:55  

keepalive-interval 1  

session-timeout 30  

delay-restore 300  

fast-convergence 

 
 

DUT_1 

configure terminal 

interface PortChannel3  

switchport trunk allowed Vlan 100,200  

no shutdown  

 

interface PortChannel1  

switchport access Vlan 100  

mclag 1 

exit  

 

 

interface Ethernet47  

channel-group 3 

 

interface Ethernet0  

channel-group 1  

! 

 

interface Vlan200  

description peer-link_vlan  

ip address 192.168.1.2/24  

 
interface Vlan100  

ip anycast-address 10.10.10.1/24  

 
 

mclag domain 1  

source-ip 192.168.1.2  

peer-ip 192.168.1.1 

peer-link PortChannel3  

mclag-system-mac 02:11:22:33:44:55  

keepalive-interval 1  

session-timeout 30  

delay-restore 300  

fast-convergence 

 

Verification 

show mclag brief #shows mclag status  

show PortChannel summary    #shows portchannel and lacp status  

show vlan                   #Check vlan status  

Show interface status      #check all connected ports are up 

 

 

Troubleshooting Tips 

  • Ensure peer-link is up and stable. 

  • Verify MC-LAG domain IDs match on both switches. 

  • Check LACP configuration on both switches and host. 

  • Confirm interface members are active in the port-channel. 

  • Look for split-brain or orphan-port warnings if peer-link fails. 

 

 

 

 

 

    • Related Articles

    • How to Configure Portchannel (Link Aggregation Group - LAG)

      Portchannel (Link Aggregation Group - LAG) Objective This document explains how to configure a port channel (Link Aggregation Group, LAG) . A port channel is a logical communication link that combines multiple physical Ethernet ports into one ...
    • How to configure BGP

      BGP (Border Gateway Protocol) Objective BGP (Border Gateway Protocol) is the protocol that enables the global routing system of the internet. It manages how packets get routed from network to network by exchanging routing and reachability information ...
    • How to configure vlan

      VLAN (Virtual Local Area Network) Objective A VLAN (Virtual Local Area Network) allows network administrators to logically segment Layer 2 broadcast domains within a switch or across multiple switches. This segmentation is independent of the physical ...
    • How to Configure Basic VRF Management

      VRF Management Objective This document explains how to configure Basic VRF (Virtual Routing and Forwarding) Management on SONiC-OS-4.4.2-Enterprise_Base. Management VRF provides a separate routing table specifically for out-of-band management ...
    • How to Configure BGP (Border Gateway Protocol)

      BGP (Border Gateway Protocol) Objective This document explains how to configure Border Gateway Protocol (BGP) on [device or platform name]. BGP is the protocol that enables the global routing system by exchanging routing information between ...